summaryrefslogtreecommitdiff
path: root/src/components/hmi_message_handler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/hmi_message_handler/CMakeLists.txt')
-rw-r--r--src/components/hmi_message_handler/CMakeLists.txt87
1 files changed, 62 insertions, 25 deletions
diff --git a/src/components/hmi_message_handler/CMakeLists.txt b/src/components/hmi_message_handler/CMakeLists.txt
index f280f97664..9559b6b00f 100644
--- a/src/components/hmi_message_handler/CMakeLists.txt
+++ b/src/components/hmi_message_handler/CMakeLists.txt
@@ -1,20 +1,50 @@
+# Copyright (c) 2014, Ford Motor Company
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+#
+# Redistributions of source code must retain the above copyright notice, this
+# list of conditions and the following disclaimer.
+#
+# Redistributions in binary form must reproduce the above copyright notice,
+# this list of conditions and the following
+# disclaimer in the documentation and/or other materials provided with the
+# distribution.
+#
+# Neither the name of the Ford Motor Company nor the names of its contributors
+# may be used to endorse or promote products derived from this software
+# without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+# ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
+# LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+# CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+# SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+# CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+# ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
+
+
include_directories (
- ./include/
- ../application_manager/include/
- ../utils/include/
- ../smart_objects/include/
- ../formatters/include/
- ../config_profile/include/
- ../media_manager/include/
- ../protocol_handler/include
- ${JSONCPP_INCLUDE_DIRECTORY}
- ${MESSAGE_BROKER_INCLUDE_DIRECTORY}
- ../config_profile/include
- ${CMAKE_SOURCE_DIR}/src/components/
- ${CMAKE_BINARY_DIR}/src/components/
- ${CMAKE_SOURCE_DIR}/src/components/dbus/include/
- ${CMAKE_SOURCE_DIR}/
- ${LOG4CXX_INCLUDE_DIRECTORY}
+ include/
+ ${COMPONENTS_DIR}/application_manager/include/
+ ${COMPONENTS_DIR}/utils/include/
+ ${COMPONENTS_DIR}/smart_objects/include/
+ ${COMPONENTS_DIR}/formatters/include/
+ ${COMPONENTS_DIR}/config_profile/include/
+ ${COMPONENTS_DIR}/media_manager/include/
+ ${COMPONENTS_DIR}/protocol_handler/include
+ ${JSONCPP_INCLUDE_DIRECTORY}
+ ${MESSAGE_BROKER_INCLUDE_DIRECTORY}
+ ${COMPONENTS_DIR}
+ ${CMAKE_BINARY_DIR}/src/components/
+ ${COMPONENTS_DIR}/dbus/include/
+ ${CMAKE_SOURCE_DIR}/
+ ${LOG4CXX_INCLUDE_DIRECTORY}
)
IF (HMIADAPTER STREQUAL "dbus")
@@ -23,22 +53,29 @@ IF (HMIADAPTER STREQUAL "dbus")
ENDIF ()
set (SOURCES
- ./src/hmi_message_handler_impl.cc
- ./src/messagebroker_adapter.cc
- ./src/hmi_message_adapter.cc
- ./src/mqueue_adapter.cc
+ ${COMPONENTS_DIR}/hmi_message_handler/src/hmi_message_handler_impl.cc
+ ${COMPONENTS_DIR}/hmi_message_handler/src/messagebroker_adapter.cc
+ ${COMPONENTS_DIR}/hmi_message_handler/src/hmi_message_adapter.cc
+ ${COMPONENTS_DIR}/hmi_message_handler/src/mqueue_adapter.cc
${DBUS_SOURCE}
)
-set (LIBRARIES
- Utils
- ${DBUS_ADAPTER}
- ${RTLIB}
+set(LIBRARIES
+ Utils
+ ${DBUS_ADAPTER}
+ ${RTLIB}
)
add_library("HMIMessageHandler" ${SOURCES})
target_link_libraries("HMIMessageHandler" ${LIBRARIES})
if(ENABLE_LOG)
- target_link_libraries("HMIMessageHandler" log4cxx -L${LOG4CXX_LIBS_DIRECTORY})
+ target_link_libraries("HMIMessageHandler" log4cxx -L${LOG4CXX_LIBS_DIRECTORY})
endif()
+
+# Tests temporary are inactivated. For details please check
+# Readme.txt in test directory of hmi_message_handler
+
+#if(BUILD_TESTS)
+# add_subdirectory(test)
+#endif()