summaryrefslogtreecommitdiff
path: root/src/components/hmi_message_handler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/hmi_message_handler/CMakeLists.txt')
-rw-r--r--src/components/hmi_message_handler/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/components/hmi_message_handler/CMakeLists.txt b/src/components/hmi_message_handler/CMakeLists.txt
index 8fafee1ac5..f66b19696d 100644
--- a/src/components/hmi_message_handler/CMakeLists.txt
+++ b/src/components/hmi_message_handler/CMakeLists.txt
@@ -74,7 +74,7 @@ endif()
target_link_libraries("HMIMessageHandler" ${LIBRARIES})
-if(ENABLE_LOG)
+if (ENABLE_LOG AND ${LOGGER_NAME} STREQUAL "LOG4CXX")
target_link_libraries("HMIMessageHandler" log4cxx -L${LOG4CXX_LIBS_DIRECTORY})
endif()