summaryrefslogtreecommitdiff
path: root/src/components/hmi_message_handler/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/hmi_message_handler/test/CMakeLists.txt')
-rw-r--r--src/components/hmi_message_handler/test/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/src/components/hmi_message_handler/test/CMakeLists.txt b/src/components/hmi_message_handler/test/CMakeLists.txt
index 9d72f3d15e..6d4041e0bf 100644
--- a/src/components/hmi_message_handler/test/CMakeLists.txt
+++ b/src/components/hmi_message_handler/test/CMakeLists.txt
@@ -37,10 +37,6 @@ include_directories (
${COMPONENTS_DIR}/hmi_message_handler/test/include
)
-if (HMIADAPTER STREQUAL "messagebroker")
- add_dependencies("hmi_message_handler_test" Boost)
-endif()
-
set(EXCLUDE_PATHS)
set(LIBRARIES
@@ -61,4 +57,9 @@ endif()
collect_sources(SOURCES "${CMAKE_CURRENT_SOURCE_DIR}" "${EXCLUDE_PATHS}")
+if (HMIADAPTER STREQUAL "messagebroker")
+ GET_PROPERTY(BOOST_LIBS_DIRECTORY GLOBAL PROPERTY GLOBAL_BOOST_LIBS)
+ list(APPEND LIBRARIES ${BOOST_LIBS_DIRECTORY}/libboost_system.so)
+endif()
+
create_test(hmi_message_handler_test "${SOURCES}" "${LIBRARIES}")