summaryrefslogtreecommitdiff
path: root/src/components/hmi_message_handler/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/hmi_message_handler/test/CMakeLists.txt')
-rw-r--r--src/components/hmi_message_handler/test/CMakeLists.txt21
1 files changed, 8 insertions, 13 deletions
diff --git a/src/components/hmi_message_handler/test/CMakeLists.txt b/src/components/hmi_message_handler/test/CMakeLists.txt
index 0d7ccd9ee1..9e855c563e 100644
--- a/src/components/hmi_message_handler/test/CMakeLists.txt
+++ b/src/components/hmi_message_handler/test/CMakeLists.txt
@@ -38,14 +38,11 @@ include_directories (
)
if (HMIADAPTER STREQUAL "messagebroker")
- set (BROKER_LIBRARIES
- message_broker_client
- message_broker_server
- )
+ set(EXCLUDE_PATHS)
+else()
+ set(EXCLUDE_PATHS hmi_message_handler_impl_test.cc)
endif()
-set(EXCLUDE_PATHS)
-
set(LIBRARIES
gmock
ApplicationManager
@@ -55,13 +52,11 @@ set(LIBRARIES
ConfigProfile
)
-if(NOT HMI_DBUS_API})
- list (APPEND EXCLUDE_PATHS
- mock_subscriber.cc
- dbus_message_adapter_test.cc
- )
-endif()
-
collect_sources(SOURCES "${CMAKE_CURRENT_SOURCE_DIR}" "${EXCLUDE_PATHS}")
+if (HMIADAPTER STREQUAL "messagebroker")
+ GET_PROPERTY(BOOST_LIBS_DIRECTORY GLOBAL PROPERTY GLOBAL_BOOST_LIBS)
+ list(APPEND LIBRARIES ${BOOST_LIBS_DIRECTORY}/libboost_system.so)
+endif()
+
create_test(hmi_message_handler_test "${SOURCES}" "${LIBRARIES}")