summaryrefslogtreecommitdiff
path: root/src/components/hmi_message_handler/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/hmi_message_handler/test/CMakeLists.txt')
-rw-r--r--src/components/hmi_message_handler/test/CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/components/hmi_message_handler/test/CMakeLists.txt b/src/components/hmi_message_handler/test/CMakeLists.txt
index 4a97e299f0..98e9fd5653 100644
--- a/src/components/hmi_message_handler/test/CMakeLists.txt
+++ b/src/components/hmi_message_handler/test/CMakeLists.txt
@@ -33,17 +33,23 @@ if(BUILD_TESTS)
include_directories (
${GMOCK_INCLUDE_DIRECTORY}
${COMPONENTS_DIR}/hmi_message_handler/include
+ ${COMPONENTS_DIR}/hmi_message_handler/test/include
)
set(LIBRARIES
gmock
ApplicationManager
HMIMessageHandler
+ jsoncpp
+ MessageBrokerClient
+ MessageBrokerServer
+ ConfigProfile
)
-set(SOURCES
- ${COMPONENTS_DIR}/hmi_message_handler/test/mqueue_adapter_test.cc
-)
+set(SOURCES
+${COMPONENTS_DIR}/hmi_message_handler/test/hmi_message_handler_impl_test.cc
+${COMPONENTS_DIR}/hmi_message_handler/test/hmi_message_adapter_test.cc
+)
if(${QT_HMI})
list (APPEND SOURCES