summaryrefslogtreecommitdiff
path: root/src/components/interfaces/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/interfaces/CMakeLists.txt')
-rw-r--r--src/components/interfaces/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/components/interfaces/CMakeLists.txt b/src/components/interfaces/CMakeLists.txt
index f1e94c0e42..6b866eb2a9 100644
--- a/src/components/interfaces/CMakeLists.txt
+++ b/src/components/interfaces/CMakeLists.txt
@@ -28,6 +28,15 @@
# ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
# POSSIBILITY OF SUCH DAMAGE.
+# Copy RPC spec submodule files to interfaces directory
+if(EXISTS ${CMAKE_SOURCE_DIR}/tools/rpc_spec/)
+ execute_process(COMMAND cp ${CMAKE_SOURCE_DIR}/tools/rpc_spec/MOBILE_API.xml ${CMAKE_CURRENT_SOURCE_DIR}/)
+ execute_process(COMMAND cp ${CMAKE_SOURCE_DIR}/tools/rpc_spec/MOBILE_API.xsd ${CMAKE_CURRENT_SOURCE_DIR}/)
+else ()
+ message( FATAL_ERROR "Missing the RPC Spec submodule" )
+ message( FATAL_ERROR "Please run `git submodule update --init` in the SDL Core source directory" )
+endif ()
+
include(${CMAKE_SOURCE_DIR}/tools/cmake/helpers/generators.cmake)
include_directories (