summaryrefslogtreecommitdiff
path: root/src/components/protocol_handler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/protocol_handler/CMakeLists.txt')
-rw-r--r--src/components/protocol_handler/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/components/protocol_handler/CMakeLists.txt b/src/components/protocol_handler/CMakeLists.txt
index d41e6cb899..7df87dd72c 100644
--- a/src/components/protocol_handler/CMakeLists.txt
+++ b/src/components/protocol_handler/CMakeLists.txt
@@ -33,6 +33,7 @@ include_directories(
${COMPONENTS_DIR}/utils/include/
${COMPONENTS_DIR}/protocol_handler/include/
${COMPONENTS_DIR}/connection_handler/include/
+ ${COMPONENTS_DIR}/config_profile/include/
${LOG4CXX_INCLUDE_DIRECTORY}
)
@@ -54,8 +55,15 @@ foreach(dir ${dirs})
message(STATUS "libraries='${dir}'")
endforeach()
+if (${CMAKE_SYSTEM_NAME} MATCHES "Windows")
+ file (GLOB inc ${COMPONENTS_DIR}/protocol_handler/include/protocol_handler/*.h)
+ string( REPLACE / \\ group ${inc} )
+ source_group("Header Files" FILES ${inc} )
+ add_library(ProtocolHandler ${inc} ${SOURCES})
+else()
+ add_library(ProtocolHandler ${SOURCES})
+endif()
-add_library(ProtocolHandler ${SOURCES})
target_link_libraries(ProtocolHandler ${LIBRARIES})
if(BUILD_TESTS)