summaryrefslogtreecommitdiff
path: root/src/components/resumption/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/resumption/test/CMakeLists.txt')
-rw-r--r--src/components/resumption/test/CMakeLists.txt18
1 files changed, 13 insertions, 5 deletions
diff --git a/src/components/resumption/test/CMakeLists.txt b/src/components/resumption/test/CMakeLists.txt
index 5481d5f80f..6fa1c07381 100644
--- a/src/components/resumption/test/CMakeLists.txt
+++ b/src/components/resumption/test/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright (c) 2016, Ford Motor Company
+# Copyright (c) 2015, Ford Motor Company
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -28,7 +28,7 @@
# ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
# POSSIBILITY OF SUCH DAMAGE.
-include(${CMAKE_SOURCE_DIR}/tools/cmake/helpers/sources.cmake)
+if(BUILD_TESTS)
include_directories(
${LOG4CXX_INCLUDE_DIRECTORY}
@@ -41,14 +41,22 @@ include_directories(
${CMAKE_BINARY_DIR}
)
-collect_sources(SOURCES ${CMAKE_CURRENT_SOURCE_DIR})
-
set(LIBRARIES
gmock
ConfigProfile
Utils
Resumption
jsoncpp
+ ConfigProfile
)
-create_test(resumption_test "${SOURCES}" "${LIBRARIES}")
+set(SOURCES
+ ${COMPONENTS_DIR}/resumption/test/last_state_test.cc
+)
+
+#file(COPY smartDeviceLink_test.ini DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
+#file(COPY app_info.dat DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
+
+create_test("resumption_test" "${SOURCES}" "${LIBRARIES}")
+
+endif()