summaryrefslogtreecommitdiff
path: root/src/components/smart_objects/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/smart_objects/CMakeLists.txt')
-rw-r--r--src/components/smart_objects/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/components/smart_objects/CMakeLists.txt b/src/components/smart_objects/CMakeLists.txt
index ef84c52ab9..6bc70f8226 100644
--- a/src/components/smart_objects/CMakeLists.txt
+++ b/src/components/smart_objects/CMakeLists.txt
@@ -34,6 +34,7 @@ include_directories(
${COMPONENTS_DIR}/include
${COMPONENTS_DIR}/smart_objects/include
${COMPONENTS_DIR}/utils/include
+ ${CMAKE_BINARY_DIR}/src/components/interfaces
${BOOST_INCLUDE_DIR}
)
@@ -45,6 +46,7 @@ collect_sources(SOURCES "${PATHS}")
add_library("SmartObjects" ${SOURCES})
target_link_libraries("SmartObjects" Utils)
+add_dependencies("SmartObjects" MOBILE_API)
if(ENABLE_LOG)
target_link_libraries("SmartObjects" log4cxx -L${LOG4CXX_LIBS_DIRECTORY})