summaryrefslogtreecommitdiff
path: root/src/components/smart_objects/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/smart_objects/test/CMakeLists.txt')
-rw-r--r--src/components/smart_objects/test/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/components/smart_objects/test/CMakeLists.txt b/src/components/smart_objects/test/CMakeLists.txt
index e0cc37e104..9c89079d94 100644
--- a/src/components/smart_objects/test/CMakeLists.txt
+++ b/src/components/smart_objects/test/CMakeLists.txt
@@ -53,5 +53,11 @@ set(EXCLUDE_PATHS
SmartObjectConvertionTime_test.cc
)
+# Enable detect Double-free, invalid free
+# AddressSanitizer is a fast memory error detector.
+# It consists of a compiler instrumentation module and a run-time library.
+set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -fno-omit-frame-pointer -fsanitize=address")
+set(CMAKE_LINKER_FLAGS_DEBUG "${CMAKE_LINKER_FLAGS_DEBUG} -fno-omit-frame-pointer -fsanitize=address")
+
collect_sources(SOURCES "${CMAKE_CURRENT_SOURCE_DIR}" "${EXCLUDE_PATHS}")
create_test(smart_object_test "${SOURCES}" "${LIBRARIES}")