summaryrefslogtreecommitdiff
path: root/src/components/transport_manager/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/transport_manager/CMakeLists.txt')
-rw-r--r--src/components/transport_manager/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/components/transport_manager/CMakeLists.txt b/src/components/transport_manager/CMakeLists.txt
index 2f734b3a05..f1edb6e298 100644
--- a/src/components/transport_manager/CMakeLists.txt
+++ b/src/components/transport_manager/CMakeLists.txt
@@ -41,6 +41,7 @@ include_directories (
${POLICY_GLOBAL_INCLUDE_PATH}/
${JSONCPP_INCLUDE_DIRECTORY}
${LOG4CXX_INCLUDE_DIRECTORY}
+ ${BOOST_INCLUDE_DIR}
)
if (CMAKE_SYSTEM_NAME STREQUAL "QNX")
@@ -72,6 +73,11 @@ else()
)
endif()
+if(BUILD_CLOUD_APP_SUPPORT)
+ GET_PROPERTY(BOOST_LIBS_DIRECTORY GLOBAL PROPERTY GLOBAL_BOOST_LIBS)
+ list(APPEND LIBRARIES boost_system boost_regex -L${BOOST_LIBS_DIRECTORY})
+endif()
+
if(BUILD_USB_SUPPORT)
if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
set(EXCLUDE_PATHS
@@ -129,3 +135,4 @@ endif()
if(BUILD_TESTS)
add_subdirectory(test)
endif()
+