summaryrefslogtreecommitdiff
path: root/src/components/transport_manager/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/transport_manager/test/CMakeLists.txt')
-rw-r--r--src/components/transport_manager/test/CMakeLists.txt42
1 files changed, 20 insertions, 22 deletions
diff --git a/src/components/transport_manager/test/CMakeLists.txt b/src/components/transport_manager/test/CMakeLists.txt
index 226bfa1885..c38804e86c 100644
--- a/src/components/transport_manager/test/CMakeLists.txt
+++ b/src/components/transport_manager/test/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright (c) 2014, Ford Motor Company
+# Copyright (c) 2015, Ford Motor Company
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -29,6 +29,7 @@
# POSSIBILITY OF SUCH DAMAGE.
if(BUILD_TESTS)
+set(TM_TEST_DIR ${COMPONENTS_DIR}/transport_manager/test)
include_directories(
${LOG4CXX_INCLUDE_DIRECTORY}
@@ -43,14 +44,14 @@ include_directories(
)
set(LIBRARIES
- gmock
- ConfigProfile
- transport_manager
- ApplicationManagerTest
- Utils
- ConfigProfile
- Resumption
- jsoncpp
+ gmock
+ ConfigProfile
+ transport_manager
+ Utils
+ ConfigProfile
+ ProtocolLibrary
+ Resumption
+ jsoncpp
)
if (BUILD_USB_SUPPORT)
@@ -65,20 +66,17 @@ if (BUILD_AVAHI_SUPPORT)
list(APPEND LIBRARIES avahi-client avahi-common)
endif()
-
set(SOURCES
- ${COMPONENTS_DIR}/transport_manager/test/mock_application.cc
- ${COMPONENTS_DIR}/transport_manager/test/transport_manager_test.cc
- ${COMPONENTS_DIR}/transport_manager/test/mock_connection_factory.cc
- ${COMPONENTS_DIR}/transport_manager/test/mock_connection.cc
- ${COMPONENTS_DIR}/transport_manager/test/mock_device.cc
- ${COMPONENTS_DIR}/transport_manager/test/mock_device_scanner.cc
- ${COMPONENTS_DIR}/transport_manager/test/raw_message_matcher.cc
- ${COMPONENTS_DIR}/transport_manager/test/dnssd_service_browser_test.cc
- ${COMPONENTS_DIR}/transport_manager/test/tcp_transport_adapter_test.cc
- ${COMPONENTS_DIR}/transport_manager/test/mock_transport_adapter.cc
-)
+ ${TM_TEST_DIR}/transport_manager_default_test.cc
+ #${TM_TEST_DIR}/transport_manager_impl_test.cc
+ #${TM_TEST_DIR}/dnssd_service_browser_test.cc
+ ${TM_TEST_DIR}/transport_adapter_test.cc
+ #${TM_TEST_DIR}/transport_adapter_listener_test.cc
+ ${TM_TEST_DIR}/tcp_transport_adapter_test.cc
+ ${TM_TEST_DIR}/tcp_device_test.cc
+ #${TM_TEST_DIR}/tcp_client_listener_test.cc
+)
create_test("transport_manager_test" "${SOURCES}" "${LIBRARIES}")
-
+file(COPY smartDeviceLink_test.ini DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
endif()