summaryrefslogtreecommitdiff
path: root/src/components/utils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/utils/CMakeLists.txt')
-rw-r--r--src/components/utils/CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/src/components/utils/CMakeLists.txt b/src/components/utils/CMakeLists.txt
index 3ebabe9043..f72d43e546 100644
--- a/src/components/utils/CMakeLists.txt
+++ b/src/components/utils/CMakeLists.txt
@@ -56,6 +56,9 @@ set (SOURCES
${UTILS_SRC_DIR}/resource_usage.cc
${UTILS_SRC_DIR}/appenders_loader.cc
${UTILS_SRC_DIR}/gen_hash.cc
+ ${UTILS_SRC_DIR}/convert_utils.cc
+ ${UTILS_SRC_DIR}/custom_string.cc
+ ${UTILS_SRC_DIR}/timer.cc
)
if(ENABLE_LOG)
@@ -80,7 +83,15 @@ if (CMAKE_SYSTEM_NAME STREQUAL "QNX")
)
endif()
-add_library("Utils" SHARED ${SOURCES})
+add_library("Utils" ${SOURCES})
+
+if (CMAKE_SYSTEM_NAME STREQUAL "QNX")
+ # --- QDB Wrapper
+ add_subdirectory(./src/qdb_wrapper)
+else ()
+ # --- SQLite Wrapper
+ add_subdirectory(./src/sqlite_wrapper)
+endif ()
if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
list(APPEND LIBRARIES dl)
@@ -91,6 +102,8 @@ if(ENABLE_LOG)
list(APPEND LIBRARIES log4cxx -L${LOG4CXX_LIBS_DIRECTORY})
list(APPEND LIBRARIES apr-1 -L${APR_LIBS_DIRECTORY})
list(APPEND LIBRARIES aprutil-1 -L${APR_UTIL_LIBS_DIRECTORY})
+ list(APPEND LIBRARIES ConfigProfile)
+
ADD_DEPENDENCIES(Utils install-3rd_party_logger)
endif()
@@ -100,6 +113,7 @@ endif()
target_link_libraries("Utils" ${LIBRARIES})
+
if(BUILD_TESTS)
add_subdirectory(test)
endif()