summaryrefslogtreecommitdiff
path: root/src/components/utils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/utils/CMakeLists.txt')
-rw-r--r--src/components/utils/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/components/utils/CMakeLists.txt b/src/components/utils/CMakeLists.txt
index bbb74dc1e1..79347f4d9f 100644
--- a/src/components/utils/CMakeLists.txt
+++ b/src/components/utils/CMakeLists.txt
@@ -13,8 +13,9 @@ set (SOURCES
./src/conditional_variable_posix.cc
./src/file_system.cc
./src/threads/posix_thread.cc
- ./src/threads/thread_manager.cc
+ ./src/threads/thread_delegate.cc
./src/threads/thread_validator.cc
+ ./src/threads/async_runner.cc
./src/lock_posix.cc
./src/rwlock_posix.cc
./src/date_time.cc
@@ -26,9 +27,11 @@ set (SOURCES
if(ENABLE_LOG)
list(APPEND SOURCES
+ ./src/logger.cc
./src/push_log.cc
./src/log_message_loop_thread.cc
./src/logger_status.cc
+ ./src/auto_trace.cc
)
endif()