summaryrefslogtreecommitdiff
path: root/src/components/utils/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/utils/test/CMakeLists.txt')
-rw-r--r--src/components/utils/test/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/components/utils/test/CMakeLists.txt b/src/components/utils/test/CMakeLists.txt
index 2db7d72d84..c09d2d7ce6 100644
--- a/src/components/utils/test/CMakeLists.txt
+++ b/src/components/utils/test/CMakeLists.txt
@@ -93,7 +93,12 @@ set(LIBRARIES
create_test(utils_test "${SOURCES}" "${LIBRARIES}")
file(COPY testscript.sh DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
-file(COPY log4cxx.properties DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
+if (${LOGGER_NAME} STREQUAL "LOG4CXX")
+ file(COPY log4cxx.properties DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
+else()
+ file(COPY boostlogconfig.ini DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
+endif()
+
file(COPY smartDeviceLink.ini DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
add_subdirectory(test_generator)