summaryrefslogtreecommitdiff
path: root/src/components/utils/test/test_generator/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/utils/test/test_generator/CMakeLists.txt')
-rw-r--r--src/components/utils/test/test_generator/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/components/utils/test/test_generator/CMakeLists.txt b/src/components/utils/test/test_generator/CMakeLists.txt
index 5a7f939659..cd4243930a 100644
--- a/src/components/utils/test/test_generator/CMakeLists.txt
+++ b/src/components/utils/test/test_generator/CMakeLists.txt
@@ -41,8 +41,8 @@ include_directories (
set(XML_NAME ${CMAKE_SOURCE_DIR}/src/components/interfaces/MOBILE_API.xml)
add_custom_target(generate_version
- COMMAND ${INTEFRACE_GENERATOR_CMD} ${XML_NAME} "mobile_apis"
- ${CMAKE_CURRENT_BINARY_DIR} "--parser-type" "sdlrpcv2"
+ COMMAND ${INTEFRACE_GENERATOR_CMD} "--source-xml" "${XML_NAME}" "--namespace" "mobile_apis"
+ "--output-dir" "${CMAKE_CURRENT_BINARY_DIR}" "--parser-type" "sdlrpcv2" "-y"
DEPENDS ${INTERFACE_GENERATOR_DEPENDENCIES} ${XML_NAME}
VERBATIM
)