summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 86d08d830..efd0632e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -797,6 +797,19 @@ m4_foreach([pers], [M32, MX32], dnl
st_MPERS([m32], [aarch64|powerpc64|s390x|sparc64|tile|x32|x86_64])
st_MPERS([mx32], [x86_64])
+AC_ARG_ENABLE([install-tests],
+ [AS_HELP_STRING([--enable-install-tests=yes|no],
+ [whether to install tests into libexec/strace,
+ default is no.])],
+ [case "$enableval" in
+ yes|no) enable_install_tests="$enableval" ;;
+ *) AC_MSG_ERROR([bad value $enableval for enable-install-tests option.
+Valid options are: yes, no.])
+ ;;
+ esac],
+ [enable_install_tests=no])
+AM_CONDITIONAL([ENABLE_INSTALL_TESTS], [test x$enable_install_tests = xyes])
+
AX_VALGRIND_DFLT([sgcheck], [off])
AX_VALGRIND_CHECK