summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 09181f4..bf88667 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,5 +1,5 @@
-bin_PROGRAMS = dlist_test get_class_dev get_device get_driver \
- get_bus_devices_list write_attr get_classdev_parent
+bin_PROGRAMS = dlist_test get_class_dev get_device get_driver write_attr \
+ get_bus_devices_list get_classdev_parent testlibsysfs
dlist_test_SOURCES = dlist_test.c
get_class_dev_SOURCES = get_class_dev.c
get_device_SOURCES = get_device.c
@@ -7,6 +7,8 @@ get_driver_SOURCES = get_driver.c
get_bus_devices_list_SOURCES = get_bus_devices_list.c
write_attr_SOURCES = write_attr.c
get_classdev_parent_SOURCES = get_classdev_parent.c
+testlibsysfs_SOURCES = test.c test_bus.c test_class.c test_dir.c \
+ test_driver.c test_root.c test_utils.c testout.c test.h
INCLUDES = -I../include
LDADD = ../lib/libsysfs.la
CFLAGS = -Wall -Wshadow -W -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls