summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 0cc3ca1..09181f4 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -9,3 +9,5 @@ write_attr_SOURCES = write_attr.c
get_classdev_parent_SOURCES = get_classdev_parent.c
INCLUDES = -I../include
LDADD = ../lib/libsysfs.la
+CFLAGS = -Wall -Wshadow -W -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls
+