summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-06-30 13:05:56 -0400
committerGitHub <noreply@github.com>2017-06-30 13:05:56 -0400
commit74d8f1c55b5aa46d2745fa4a74ae9fced6a3cab8 (patch)
treef25c50b7554b2e02dd42e2403c5e12c605b19be9 /Makefile.am
parent9432a05c541d64e807949c416604cc04f4107307 (diff)
parent2416f73be12dbac0d121f23f654f7019ae3e4ca8 (diff)
downloadsystemd-74d8f1c55b5aa46d2745fa4a74ae9fced6a3cab8.tar.gz
Merge pull request #6194 from keszybz/urandom-magic
Fall back to /dev/urandom less and other random number improvements.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 07995680fe..3fb68dd385 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1624,6 +1624,7 @@ tests += \
test-conf-parser \
test-capability \
test-async \
+ test-random-util \
test-ratelimit \
test-condition \
test-uid-range \
@@ -1945,6 +1946,12 @@ test_fstab_util_SOURCES = \
test_fstab_util_LDADD = \
libsystemd-shared.la
+test_random_util_SOURCES = \
+ src/test/test-random-util.c
+
+test_random_util_LDADD = \
+ libsystemd-shared.la
+
test_ratelimit_SOURCES = \
src/test/test-ratelimit.c