summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Hajnoczi <stefanha@redhat.com>2017-01-10 13:35:18 +0000
committerStefan Hajnoczi <stefanha@redhat.com>2017-01-10 15:27:00 +0000
commit4e0399e69b369f3d3543285592e977063cdcc014 (patch)
tree0a8ba1217ce009ab0365a4d94830a348a06b7b17 /configure.ac
parent6534c8d35ff03ae2b3d2e8c26a175ee39dbb4af0 (diff)
downloadsystemd-4e0399e69b369f3d3543285592e977063cdcc014.tar.gz
missing.h: add AF_VSOCK bits
Ubuntu 14.04 (Trusty) kernel header packages ship without <linux/vm_sockets.h>. Only struct sockaddr_vm and VMADDR_CID_ANY will be needed by systemd and they are simple enough to go in missing.h. CentOS 7 <sys/socket.h> does not define AF_VSOCK. Define it so the code can compile although actual socket(2) calls may fail at runtime if the address family isn't available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 11bd46cbab..371158efe5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -285,6 +285,7 @@ AM_CONDITIONAL([HAVE_PYTHON], [test "x$have_python" = "xyes"])
AC_CHECK_HEADERS([sys/capability.h], [], [AC_MSG_ERROR([*** POSIX caps headers not found])])
AC_CHECK_HEADERS([linux/btrfs.h], [], [])
AC_CHECK_HEADERS([linux/memfd.h], [], [])
+AC_CHECK_HEADERS([linux/vm_sockets.h], [], [], [#include <sys/socket.h>])
# unconditionally pull-in librt with old glibc versions
AC_SEARCH_LIBS([clock_gettime], [rt], [], [])