summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFranck Bui <fbui@suse.com>2017-05-09 14:02:37 +0200
committerFranck Bui <fbui@suse.com>2017-05-10 10:19:37 +0200
commitb14e1b43942f1f61146d9c6e519bd09688731797 (patch)
treef6d239791839bbcd1038974ca821e819cfb090bb /configure.ac
parentb20b0b66066cef87da779b92aa7a18c7c3f71a2c (diff)
downloadsystemd-b14e1b43942f1f61146d9c6e519bd09688731797.tar.gz
sysusers: make group shadow support configurable
Some distros (openSUSE) don't have group shadow support enabled. This can lead to the following error: # systemd-sysusers Creating group foofoo with gid 478. # systemd-sysusers # groupdel foofoo # systemd-sysusers Creating group foofoo with gid 478. Failed to write files: File exists This patch adds --disable-gshadow option to configure. If used, systemd-sysvusers won't consider /etc/gshadow.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f59f3faf38..4851e5537d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1092,6 +1092,11 @@ if test "x$enable_sysusers" != "xno"; then
fi
AM_CONDITIONAL(ENABLE_SYSUSERS, [test "$have_sysusers" = "yes"])
+AC_ARG_ENABLE(gshadow, AS_HELP_STRING([--disable-gshadow], [disable shadow group support]))
+AS_IF([test "x${enable_gshadow}" != "xno"], [
+ AC_DEFINE(ENABLE_GSHADOW, 1, [shadow group support is enabled])
+])
+
# ------------------------------------------------------------------------------
have_firstboot=no
AC_ARG_ENABLE(firstboot, AS_HELP_STRING([--disable-firstboot], [disable firstboot support]))