summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorsteelman <stlman@poczta.fm>2017-03-15 00:16:47 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-03-14 19:16:47 -0400
commitff2e33db54719bfe8feea833571652318c6d197c (patch)
treee89f5a8305edb95753b3e80fcef636a01596186d /configure.ac
parent5c50321ca9c660dac39976ab29ed2f28f872628d (diff)
downloadsystemd-ff2e33db54719bfe8feea833571652318c6d197c.tar.gz
build-sys: make RPM macros installation path configurable (#5564)
--with-rpmmacrosdir=no disables installation of the macros.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1efeb3a73e..c0e5ec4fae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1577,6 +1577,12 @@ AC_ARG_WITH([pamconfdir],
AM_CONDITIONAL(ENABLE_PAM_CONFIG, [test "$with_pamconfdir" != "no"])
AX_NORMALIZE_PATH([with_pamconfdir])
+AC_ARG_WITH([rpmmacrosdir],
+ AS_HELP_STRING([--with-rpmmacrosdir=DIR], [directory to store macros for RPM]),
+ [], [with_rpmmacrosdir=\${prefix}/lib/rpm/macros.d])
+AM_CONDITIONAL(ENABLE_RPM_MACROS, [test "$with_rpmmacrosdir" != "no"])
+AX_NORMALIZE_PATH([with_rpmmacrosdir])
+
AC_ARG_ENABLE([split-usr],
AS_HELP_STRING([--enable-split-usr], [assume that /bin, /sbin aren't symlinks into /usr]),
[],
@@ -1647,6 +1653,7 @@ AC_SUBST([bashcompletiondir], [$with_bashcompletiondir])
AC_SUBST([zshcompletiondir], [$with_zshcompletiondir])
AC_SUBST([pamlibdir], [$with_pamlibdir])
AC_SUBST([pamconfdir], [$with_pamconfdir])
+AC_SUBST([rpmmacrosdir], [$with_rpmmacrosdir])
AC_SUBST([rootprefix], [$with_rootprefix])
AC_SUBST([rootlibdir], [$with_rootlibdir])
@@ -1746,6 +1753,7 @@ AC_MSG_RESULT([
build Python: ${PYTHON}
PAM modules dir: ${with_pamlibdir}
PAM configuration dir: ${with_pamconfdir}
+ RPM macros dir: ${with_rpmmacrosdir}
D-Bus policy dir: ${with_dbuspolicydir}
D-Bus session dir: ${with_dbussessionservicedir}
D-Bus system dir: ${with_dbussystemservicedir}