summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-13 20:30:07 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-23 21:47:28 -0400
commit4390be305b235e647dd18c95c74d79a2a085d561 (patch)
tree19ea1b49d3f8322cfa9dd2296a3fa70faa56252b /man/meson.build
parent9ac47f38151808712f1bdcae8e2eb42a0b53e5ca (diff)
downloadsystemd-4390be305b235e647dd18c95c74d79a2a085d561.tar.gz
meson: replace yes/no/auto with true/false/auto
This doesn't feel as natural, but is more consistent with the boolean options which require true/false, and allows setting of options without knowing of which type the option is.
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/man/meson.build b/man/meson.build
index 1b7b5a2419..6efec40695 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -9,9 +9,9 @@ subdir('rules')
want_man = get_option('man')
want_html = get_option('html')
xsltproc = find_program('xsltproc',
- required : want_man == 'yes' or want_html == 'yes')
-want_man = want_man != 'no' and xsltproc.found()
-want_html = want_html != 'no' and xsltproc.found()
+ required : want_man == 'true' or want_html == 'true')
+want_man = want_man != 'false' and xsltproc.found()
+want_html = want_html != 'false' and xsltproc.found()
xsltproc_flags = [
'--nonet',