summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-05 19:44:41 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-23 21:47:26 -0400
commit04e3eb46e316dacc990bed1e520df44327bbf5c1 (patch)
tree056d0b6d47df02b98aa70154b15f990a246d25e3 /man/meson.build
parent78b68dcb55c4da1148296ca5b101d23fa3898f8a (diff)
downloadsystemd-04e3eb46e316dacc990bed1e520df44327bbf5c1.tar.gz
meson: add rule to generate custom-entities.ent
This is a bit bare-bones, but should work for now. Maybe in the future we'll have a way to make meson generate it for us, without specifying all the names by hand.
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/man/meson.build b/man/meson.build
index 0f0bbd6ffc..c78c24d3e6 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -20,7 +20,11 @@ xsltproc_flags = [
custom_man_xsl = files('custom-man.xsl')
custom_html_xsl = files('custom-man.xsl')
-custom_entities_ent = files('custom-entities.ent')
+
+custom_entities_ent = configure_file(
+ input : 'custom-entities.ent.in',
+ output : 'custom-entities.ent',
+ configuration : conf)
foreach tuple : manpages
stem = tuple[0]
@@ -48,6 +52,7 @@ foreach tuple : manpages
input : xml,
output : [man] + manaliases,
command : [xsltproc, '-o', '@OUTPUT0@'] + xsltproc_flags + [custom_man_xsl, '@INPUT@'],
+ depend_files : custom_entities_ent,
install : install,
install_dir : mandirn)
@@ -55,7 +60,8 @@ foreach tuple : manpages
html,
input : xml,
output : [html] + htmlaliases,
- command : [xsltproc, '-o', '@OUTPUT0@'] + xsltproc_flags + [custom_html_xsl, '@INPUT@'])
+ command : [xsltproc, '-o', '@OUTPUT0@'] + xsltproc_flags + [custom_html_xsl, '@INPUT@'],
+ depend_files : custom_entities_ent)
if not install
message('Skipping @0@.@1@ because @2@ is @3@'.format(stem, section, condition, install))