summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2019-07-11 00:00:51 +0200
committerGitHub <noreply@github.com>2019-07-11 00:00:51 +0200
commit261e7d927020b673c09027c04fc2fa19e8ece1af (patch)
tree71dc83057cbf0bc67bd6c53ad02a366deaaa933c /meson.build
parent08945b59d1f6825c4e7500093db5226766acf620 (diff)
parent2a8f53c67b5d4633ec40e6cd940e222d4b8d3217 (diff)
downloadsystemd-261e7d927020b673c09027c04fc2fa19e8ece1af.tar.gz
Merge pull request #12755 from keszybz/short-identifiers
Allow using unit names in status messages
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 14a56c29c8..93d6914627 100644
--- a/meson.build
+++ b/meson.build
@@ -189,6 +189,7 @@ if pamconfdir == ''
endif
memory_accounting_default = get_option('memory-accounting-default')
+status_unit_format_default = get_option('status-unit-format-default')
conf.set_quoted('PKGSYSCONFDIR', pkgsysconfdir)
conf.set_quoted('SYSTEM_CONFIG_UNIT_PATH', join_paths(pkgsysconfdir, 'system'))
@@ -242,6 +243,7 @@ conf.set_quoted('USER_KEYRING_PATH', join_paths(pkgsysc
conf.set_quoted('DOCUMENT_ROOT', join_paths(pkgdatadir, 'gatewayd'))
conf.set10('MEMORY_ACCOUNTING_DEFAULT', memory_accounting_default)
conf.set_quoted('MEMORY_ACCOUNTING_DEFAULT_YES_NO', memory_accounting_default ? 'yes' : 'no')
+conf.set('STATUS_UNIT_FORMAT_DEFAULT', 'STATUS_UNIT_FORMAT_' + status_unit_format_default.to_upper())
substs.set('prefix', prefixdir)
substs.set('rootprefix', rootprefixdir)
@@ -282,6 +284,7 @@ substs.set('SYSTEM_SYSVINIT_PATH', sysvinit_path)
substs.set('SYSTEM_SYSVRCND_PATH', sysvrcnd_path)
substs.set('RC_LOCAL_SCRIPT_PATH_START', get_option('rc-local'))
substs.set('MEMORY_ACCOUNTING_DEFAULT', memory_accounting_default ? 'yes' : 'no')
+substs.set('STATUS_UNIT_FORMAT_DEFAULT', status_unit_format_default)
substs.set('HIGH_RLIMIT_NOFILE', conf.get('HIGH_RLIMIT_NOFILE'))
substs.set('BUILD_ROOT', meson.current_build_dir())