summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2018-11-15 22:09:29 +0100
committerLennart Poettering <lennart@poettering.net>2018-11-27 09:44:40 +0100
commit35a1ff4cfe82810e7f52db07b67793af8c54c9f6 (patch)
tree35cbc5c1280160c509c794510ff4bb3c005b0804 /meson.build
parent7af67e9a8b1f10c6aaeff56910957907ef852cee (diff)
downloadsystemd-35a1ff4cfe82810e7f52db07b67793af8c54c9f6.tar.gz
add new run-generator
This is really useful for running commands like this: # systemd-run -i someimage.raw -b systemd.run='"some command line"' This will now run the command line inside a small Type=oneshot service and even propagate the exit code of the command back to the parent. And all that with the full system booted up. By default this causes the system to shutdown right after the command completed, but this can be tweaked with systemd.run_success_action= and systemd.run_failure_action=. Note that when used in VMs the exit status can of course not be propagate, as VMs don't really know a concept for that.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8b51d032b8..2c8935c833 100644
--- a/meson.build
+++ b/meson.build
@@ -1631,6 +1631,14 @@ executable('systemd-debug-generator',
install : true,
install_dir : systemgeneratordir)
+executable('systemd-run-generator',
+ 'src/run-generator/run-generator.c',
+ include_directories : includes,
+ link_with : [libshared],
+ install_rpath : rootlibexecdir,
+ install : true,
+ install_dir : systemgeneratordir)
+
executable('systemd-fstab-generator',
'src/fstab-generator/fstab-generator.c',
'src/core/mount-setup.c',