summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-06-21 06:05:15 -0400
committerLennart Poettering <lennart@poettering.net>2017-06-21 12:05:15 +0200
commit4b57a2720029ba0b9c7bb676b1444cb574437f20 (patch)
tree376f5f8b3d963763cb01ea987a1bfccc879ea8d8 /meson.build
parent9d3c1efaa38843b4e71e4072922a8c4ff7f44a04 (diff)
downloadsystemd-4b57a2720029ba0b9c7bb676b1444cb574437f20.tar.gz
meson: add -pthreads and more libs when -Dlink-udev-shared=false (#6159)
Three binaries would fail to link when ld.bfd was used and link-udev-shared was false. Add -pthreads (again) to the failing binaries and synchronize the dependency list between libsystemd-shared .a and .so versions. Apart from allowing the build to succeed, this shouldn't have much effect becuase systemd-networkd was already using pthreads. Fixes #5828.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 0c6293dba4..cab08dc67d 100644
--- a/meson.build
+++ b/meson.build
@@ -2175,6 +2175,7 @@ if conf.get('ENABLE_NETWORKD', false)
libsystemd_network,
libudev_internal,
libshared],
+ dependencies : [threads],
install_rpath : rootlibexecdir,
install : true,
install_dir : rootlibexecdir)