summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-10-03 10:32:34 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-10-03 10:32:34 +0200
commit4b9545f19e8ae9b232ca1083cff8140dc24390f6 (patch)
tree4c1b3301bebf65b781223eb6942a2dae6aefd903 /meson.build
parent8bdaf088ca22c4c12aee86e3a5e46998d042e21b (diff)
downloadsystemd-4b9545f19e8ae9b232ca1083cff8140dc24390f6.tar.gz
build-sys: change all HAVE_DECL_ macros to HAVE_
This is a legacy of autotools, where one detection routine used a different prefix then the others. $ git grep -e HAVE_DECL_ -l|xargs sed -i s/HAVE_DECL_/HAVE_/g
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 859454b76d..2673c2c9e2 100644
--- a/meson.build
+++ b/meson.build
@@ -419,7 +419,7 @@ foreach decl : [['IFLA_INET6_ADDR_GEN_MODE', 'linux/if_link.h'],
]
prefix = decl.length() > 2 ? decl[2] : ''
have = cc.has_header_symbol(decl[1], decl[0], prefix : prefix)
- conf.set10('HAVE_DECL_' + decl[0], have)
+ conf.set10('HAVE_' + decl[0], have)
endforeach
skip = false
@@ -452,15 +452,15 @@ foreach ident : [
]
have = cc.has_function(ident[0], prefix : ident[1])
- conf.set10('HAVE_DECL_' + ident[0].to_upper(), have)
+ conf.set10('HAVE_' + ident[0].to_upper(), have)
endforeach
if cc.has_function('getrandom', prefix : '''#include <sys/random.h>''')
conf.set('USE_SYS_RANDOM_H', true)
- conf.set10('HAVE_DECL_GETRANDOM', true)
+ conf.set10('HAVE_GETRANDOM', true)
else
have = cc.has_function('getrandom', prefix : '''#include <linux/random.h>''')
- conf.set10('HAVE_DECL_GETRANDOM', have)
+ conf.set10('HAVE_GETRANDOM', have)
endif
#####################################################################