summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDimitri John Ledkov <xnox@ubuntu.com>2017-08-02 13:41:18 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-08-02 08:41:18 -0400
commit582faeb461aa0dd01b55bf6c9b1433532fc927d3 (patch)
tree74b608e0176ff3902f2b6aa783aa4ec712908649 /meson.build
parentd2a1ba103b4ea22764953d795c36db3d492d50c9 (diff)
downloadsystemd-582faeb461aa0dd01b55bf6c9b1433532fc927d3.tar.gz
modprobe.d: ship drop-in to set bonding max_bonds to 0 (#6448)
This allows networkd to correctly manage bond0 using networkd, when requested by the user. Fixes #5971 #6184
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f73729d392..8dd3381c65 100644
--- a/meson.build
+++ b/meson.build
@@ -81,6 +81,7 @@ polkitpkladir = join_paths(localstatedir, 'lib/polkit-1/localauthority/10-vendor
varlogdir = join_paths(localstatedir, 'log')
xinitrcdir = join_paths(sysconfdir, 'X11/xinit/xinitrc.d')
rpmmacrosdir = get_option('rpmmacrosdir')
+modprobedir = join_paths(rootlibdir, 'modprobe.d')
# Our own paths
pkgdatadir = join_paths(datadir, 'systemd')
@@ -2307,6 +2308,8 @@ install_data('xorg/50-systemd-user.sh',
install_dir : xinitrcdir)
install_data('system-preset/90-systemd.preset',
install_dir : systempresetdir)
+install_data('modprobe.d/systemd.conf',
+ install_dir : modprobedir)
install_data('README',
'NEWS',
'CODING_STYLE',
@@ -2393,6 +2396,7 @@ status = [
'PAM modules dir: @0@'.format(pamlibdir),
'PAM configuration dir: @0@'.format(pamconfdir),
'RPM macros dir: @0@'.format(rpmmacrosdir),
+ 'modprobe.d dir: @0@'.format(modprobedir),
'D-Bus policy dir: @0@'.format(dbuspolicydir),
'D-Bus session dir: @0@'.format(dbussessionservicedir),
'D-Bus system dir: @0@'.format(dbussystemservicedir),