summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-05-13 13:23:28 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-05-13 15:50:44 -0400
commit94e2523b702c4490950017171902ea6bc8f776cb (patch)
tree881609e3c55ac5ee9345663954e404acc7708744 /meson.build
parent3bf47e73929dbc9361574af1df84e437901a5538 (diff)
downloadsystemd-94e2523b702c4490950017171902ea6bc8f776cb.tar.gz
tests,meson: add test-bus-vtable, compiled as C and C++
This test is mostly a compilation test that checks that various defines in sd-bus-vtable.h are valid C++. The code is executed, but the results are not checked (apart from sd-bus functions not returning an error). test-bus-objects contains pretty extensive tests for this functionality. The C++ version is only added to meson, since it's simpler there. Because of the .cc extension, meson will compile the executable with c++. This test is necessary to properly check the macros in sd-bus-vtable.h. Just running the headers through g++ is not enough, because the macros are not exercised. Follow-up for #5941.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index bd05757b87..0f90da1ee9 100644
--- a/meson.build
+++ b/meson.build
@@ -224,6 +224,12 @@ cc = meson.get_compiler('c')
pkgconfig = import('pkgconfig')
check_compilation_sh = find_program('tools/meson-check-compilation.sh')
+cxx = find_program('c++', required : false)
+if cxx.found()
+ # Used only for tests
+ add_languages('cpp')
+endif
+
foreach arg : ['-Wundef',
'-Wlogical-op',
'-Wmissing-include-dirs',