summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2020-11-26 12:46:10 +0100
committerLennart Poettering <lennart@poettering.net>2020-12-17 20:00:41 +0100
commit2bc5c425e65a140f2eaf31bdf23a277e32ce38a7 (patch)
tree17c0c3b6634109c30951b8189fb357ae86d513fd /meson.build
parente3fb662b6710134e3d52ea46ef2eb2c412c377c4 (diff)
downloadsystemd-2bc5c425e65a140f2eaf31bdf23a277e32ce38a7.tar.gz
cryptsetup: add fido2 support
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9a7f9be3cb..c64edda8e3 100644
--- a/meson.build
+++ b/meson.build
@@ -2367,9 +2367,10 @@ executable(
if conf.get('HAVE_LIBCRYPTSETUP') == 1
systemd_cryptsetup_sources = files('''
- src/cryptsetup/cryptsetup-pkcs11.h
+ src/cryptsetup/cryptsetup-fido2.h
src/cryptsetup/cryptsetup-keyfile.c
src/cryptsetup/cryptsetup-keyfile.h
+ src/cryptsetup/cryptsetup-pkcs11.h
src/cryptsetup/cryptsetup.c
'''.split())
@@ -2377,6 +2378,10 @@ if conf.get('HAVE_LIBCRYPTSETUP') == 1
systemd_cryptsetup_sources += files('src/cryptsetup/cryptsetup-pkcs11.c')
endif
+ if conf.get('HAVE_LIBFIDO2') == 1
+ systemd_cryptsetup_sources += files('src/cryptsetup/cryptsetup-fido2.c')
+ endif
+
executable(
'systemd-cryptsetup',
systemd_cryptsetup_sources,