summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2019-10-30 16:29:42 +0100
committerLennart Poettering <lennart@poettering.net>2019-12-04 10:34:03 +0100
commit5ead4e85f6b58a099269b27def1cd03c4526ae19 (patch)
treee6f230f0fcef0554b792d9d23e3d8c5d38f4c979 /meson.build
parent5f152f43d04e5aad6a3f98f45f020a66e3aac717 (diff)
downloadsystemd-5ead4e85f6b58a099269b27def1cd03c4526ae19.tar.gz
missing: add rt_sigqueueinfo() syscall definition
This is not a new system call at all (since kernel 2.2), however it's not exposed in glibc (a wrapper is exposed however in sigqueue(), but it substantially simplifies the system call). Since we want a nice fallback for sending signals on non-pidfd systems for pidfd_send_signal() let's wrap rt_sigqueueinfo() since it takes the same siginfo_t parameter.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index edde42ea74..3085af49fd 100644
--- a/meson.build
+++ b/meson.build
@@ -525,6 +525,10 @@ foreach ident : [
#include <unistd.h>
#include <signal.h>
#include <sys/wait.h>'''],
+ ['rt_sigqueueinfo', '''#include <stdlib.h>
+ #include <unistd.h>
+ #include <signal.h>
+ #include <sys/wait.h>'''],
]
have = cc.has_function(ident[0], prefix : ident[1], args : '-D_GNU_SOURCE')