summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2018-05-02 13:56:28 +0900
committerYu Watanabe <watanabe.yu+github@gmail.com>2018-05-10 15:31:00 +0900
commitad7aa7606168a47c6b909964e050a59b5cce0682 (patch)
tree1f6132f9000b94639319d8645ffd4fba592b9a61 /meson.build
parent8ea9fad715d9cf4ce59c3583f5ad1d8abf9e320d (diff)
downloadsystemd-ad7aa7606168a47c6b909964e050a59b5cce0682.tar.gz
meson: use array type option
Array type option is supported since 0.44.0.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build21
1 files changed, 9 insertions, 12 deletions
diff --git a/meson.build b/meson.build
index 9c6bdf91b1..aa07ed8e9b 100644
--- a/meson.build
+++ b/meson.build
@@ -760,20 +760,17 @@ conf.set_quoted('GETTEXT_PACKAGE', meson.project_name())
substs.set('SUSHELL', get_option('debug-shell'))
substs.set('DEBUGTTY', get_option('debug-tty'))
-debug = get_option('debug')
enable_debug_hashmap = false
enable_debug_mmap_cache = false
-if debug != ''
- foreach name : debug.split(',')
- if name == 'hashmap'
- enable_debug_hashmap = true
- elif name == 'mmap-cache'
- enable_debug_mmap_cache = true
- else
- message('unknown debug option "@0@", ignoring'.format(name))
- endif
- endforeach
-endif
+foreach name : get_option('debug')
+ if name == 'hashmap'
+ enable_debug_hashmap = true
+ elif name == 'mmap-cache'
+ enable_debug_mmap_cache = true
+ else
+ message('unknown debug option "@0@", ignoring'.format(name))
+ endif
+endforeach
conf.set10('ENABLE_DEBUG_HASHMAP', enable_debug_hashmap)
conf.set10('ENABLE_DEBUG_MMAP_CACHE', enable_debug_mmap_cache)