summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2019-07-04 19:06:26 +0200
committerLennart Poettering <lennart@poettering.net>2020-01-28 22:36:41 +0100
commit26cf9fb7f833e7f18dc7c439a1da7027a241e2e6 (patch)
tree3a5891364c38359dad6cc6f108879ab3658a61cb /meson.build
parent4aa0a8ac3e548219d380a0c566242338eab185da (diff)
downloadsystemd-26cf9fb7f833e7f18dc7c439a1da7027a241e2e6.tar.gz
home: add pam_systemd_home.so PAM hookup
In a way fixes: https://bugs.freedesktop.org/show_bug.cgi?id=67474
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 76f8153cd1..ea69276019 100644
--- a/meson.build
+++ b/meson.build
@@ -2102,6 +2102,26 @@ if conf.get('ENABLE_HOMED') == 1
install_rpath : rootlibexecdir,
install : true,
install_dir : rootbindir)
+
+ if conf.get('HAVE_PAM') == 1
+ version_script_arg = join_paths(project_source_root, pam_systemd_home_sym)
+ pam_systemd = shared_library(
+ 'pam_systemd_home',
+ pam_systemd_home_c,
+ name_prefix : '',
+ include_directories : includes,
+ link_args : ['-shared',
+ '-Wl,--version-script=' + version_script_arg],
+ link_with : [libsystemd_static,
+ libshared_static],
+ dependencies : [threads,
+ libpam,
+ libpam_misc,
+ libcrypt],
+ link_depends : pam_systemd_home_sym,
+ install : true,
+ install_dir : pamlibdir)
+ endif
endif
foreach alias : ['halt', 'poweroff', 'reboot', 'runlevel', 'shutdown', 'telinit']