summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2020-01-30 23:25:12 +0900
committerLennart Poettering <lennart@poettering.net>2020-02-02 17:13:08 +0100
commit60d0a5098b2b58c105d86e4eacad691a3bef8ffd (patch)
tree5fccea5838a583934de1cfdfce20c5e29aa9f7ec /meson.build
parentc757517d98ade27b9938635afb52e5621da9f1cb (diff)
downloadsystemd-60d0a5098b2b58c105d86e4eacad691a3bef8ffd.tar.gz
util: uid_t, gid_t, and pid_t must be 32bit
We already have assert_cc(sizeof(uid_t) == sizeof(uint32_t)) or friends at various places.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 0 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 9468b67109..184dbf5d24 100644
--- a/meson.build
+++ b/meson.build
@@ -449,9 +449,6 @@ conf.set('_GNU_SOURCE', true)
conf.set('__SANE_USERSPACE_TYPES__', true)
conf.set10('HAVE_WSTRINGOP_TRUNCATION', has_wstringop_truncation)
-conf.set('SIZEOF_PID_T', cc.sizeof('pid_t', prefix : '#include <sys/types.h>'))
-conf.set('SIZEOF_UID_T', cc.sizeof('uid_t', prefix : '#include <sys/types.h>'))
-conf.set('SIZEOF_GID_T', cc.sizeof('gid_t', prefix : '#include <sys/types.h>'))
conf.set('SIZEOF_DEV_T', cc.sizeof('dev_t', prefix : '#include <sys/types.h>'))
conf.set('SIZEOF_INO_T', cc.sizeof('ino_t', prefix : '#include <sys/types.h>'))
conf.set('SIZEOF_TIME_T', cc.sizeof('time_t', prefix : '#include <sys/time.h>'))