summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Klumpp <matthias@tenstral.net>2021-01-08 23:59:38 +0100
committerMatthias Klumpp <matthias@tenstral.net>2021-01-12 23:15:12 +0100
commit8f20232fcb52dbe6255f3df6101fc057af90bcfa (patch)
treeea0fc53090f6b2bc14e1a72a93ef3e24a2bd37d9 /meson.build
parentbd47b0dac4a1ff6e686c99b9958693e86d44007b (diff)
downloadsystemd-8f20232fcb52dbe6255f3df6101fc057af90bcfa.tar.gz
localed: Run locale-gen if available to generate missing locale
This change improves integration with distributions using locale-gen to generate missing locale on-demand, like Debian-based distributions (Debian/Ubuntu/PureOS/Tanglu/...) and Arch Linux. We only ever enable new locales for generation, and never disable them. Furthermore, we only generate UTF-8 locale. This feature is only used if explicitly enabled at compile-time, and will also be inert at runtime if the locale-gen binary is missing.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 841dd97003..4a56ee3ee4 100644
--- a/meson.build
+++ b/meson.build
@@ -832,6 +832,14 @@ if default_locale == ''
endif
conf.set_quoted('SYSTEMD_DEFAULT_LOCALE', default_locale)
+localegen_path = get_option('localegen-path')
+have = false
+if localegen_path != ''
+ conf.set_quoted('LOCALEGEN_PATH', localegen_path)
+ have = true
+endif
+conf.set10('HAVE_LOCALEGEN', have)
+
conf.set_quoted('GETTEXT_PACKAGE', meson.project_name())
service_watchdog = get_option('service-watchdog')