summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-09-12 11:02:58 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-09-13 12:07:34 +0200
commitd3da291eb071ce35f530fda690a300e44b99b53e (patch)
tree0f36ca637c5683ba87f60e06434eec584255dc23 /meson.build
parentf57d003cb6ccda702d2777aa2bfe3907fd683091 (diff)
downloadsystemd-d3da291eb071ce35f530fda690a300e44b99b53e.tar.gz
meson: disable "slow tests" too when tests are generally disabled
We would have a strange situation where after setting -Dslow-tests=true -Dtests=false we'd get mostly the slow tests (plus some other ones which I'll fix in subsequent commit). Let's simplify things by making -Dtests=false just disable those tests too.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 5 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index a97c5fcffc..28fd4da365 100644
--- a/meson.build
+++ b/meson.build
@@ -270,7 +270,11 @@ pkgconfig = import('pkgconfig')
check_compilation_sh = find_program('tools/meson-check-compilation.sh')
meson_build_sh = find_program('tools/meson-build.sh')
-if get_option('tests') != 'false'
+want_tests = get_option('tests')
+slow_tests = want_tests != 'false' and get_option('slow-tests')
+install_tests = get_option('install-tests')
+
+if want_tests != 'false'
cxx = find_program('c++', required : false)
if cxx.found()
# Used only for tests
@@ -1291,9 +1295,6 @@ conf.set10('ENABLE_NSS', enable_nss)
conf.set10('ENABLE_TIMEDATECTL', get_option('timedated') or get_option('timesyncd'))
-want_tests = get_option('tests')
-install_tests = get_option('install-tests')
-slow_tests = get_option('slow-tests')
tests = []
fuzzers = []