summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEvegeny Vereshchagin <evvers@ya.ru>2018-05-18 10:52:17 +0000
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-05-19 15:32:47 +0200
commit2f09974f34c2093a8def567d2f76c8ab84a561b8 (patch)
treeea074da69afbb7ca37bde92e7a7a898edab5a9f5 /meson.build
parent4aab839c90e4f390956cb777237c1acb115ebeae (diff)
downloadsystemd-2f09974f34c2093a8def567d2f76c8ab84a561b8.tar.gz
meson: use run_target for generating tags with ctags
In https://github.com/systemd/systemd/pull/6561, `run_target` was changed to `custom_target`, which inadvertently caused relative paths to be passed to ctags due to https://github.com/mesonbuild/meson/issues/3589. The switch to `run_target` causes absolute paths to be passed again and makes it easier to jump from file to file, hopefully delaying the need to exit Vim :-)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 469737819d..92275f1711 100644
--- a/meson.build
+++ b/meson.build
@@ -2735,9 +2735,8 @@ if git.found()
'tags',
output : 'tags',
command : [env, 'etags', '-o', '@0@/TAGS'.format(meson.current_source_dir())] + all_files)
- custom_target(
+ run_target(
'ctags',
- output : 'ctags',
command : [env, 'ctags', '-o', '@0@/tags'.format(meson.current_source_dir())] + all_files)
endif