summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-08-19 19:11:30 +0200
committerLukáš Nykrýn <lnykryn@redhat.com>2019-01-14 13:04:18 +0100
commit9c1b72de44e68ad80be7c0b98df110e7b127072d (patch)
tree04830265e0f33fb2ded548981294909e1fb34ad1 /meson.build
parent13d819cc795d8c3695ce7288436ad569366073f6 (diff)
downloadsystemd-9c1b72de44e68ad80be7c0b98df110e7b127072d.tar.gz
meson: rename -Ddebug to -Ddebug-extra
Meson added -Doptimization and -Ddebug options, which obviously causes a conflict with our -Ddebug options. Let's rename it. Fixes #9883. Cherry-picked from: 8f6b442a78d0b485f044742ad90b2e8271b4e68e
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f308db2631..ebc55872c9 100644
--- a/meson.build
+++ b/meson.build
@@ -769,7 +769,7 @@ substs.set('DEBUGTTY', get_option('debug-tty'))
enable_debug_hashmap = false
enable_debug_mmap_cache = false
-foreach name : get_option('debug')
+foreach name : get_option('debug-extra')
if name == 'hashmap'
enable_debug_hashmap = true
elif name == 'mmap-cache'