summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2018-04-26 21:39:05 +0200
committerGitHub <noreply@github.com>2018-04-26 21:39:05 +0200
commit385f3a0d8dcb4ebf2834dcaf06a3692128ee11d8 (patch)
tree874c9f37f667a25329b24817b0ef4c4ade8555d8 /meson.build
parentbe737420b7cd9489bfa2d518a577a0b56cb51862 (diff)
parent79bb7cb3ffb1ea307cc8fc9b84f02dd971f52fcc (diff)
downloadsystemd-385f3a0d8dcb4ebf2834dcaf06a3692128ee11d8.tar.gz
Merge pull request #7599 from keszybz/slice-templates
Make user@.service independent of logind
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2986b5b575..93cbabf260 100644
--- a/meson.build
+++ b/meson.build
@@ -1672,6 +1672,14 @@ if conf.get('ENABLE_LOGIND') == 1
endif
endif
+executable('systemd-user-runtime-dir',
+ user_runtime_dir_sources,
+ include_directories : includes,
+ link_with : [libshared, liblogind_core],
+ install_rpath : rootlibexecdir,
+ install : true,
+ install_dir : rootlibexecdir)
+
if conf.get('HAVE_PAM') == 1
executable('systemd-user-sessions',
'src/user-sessions/user-sessions.c',