summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-05-28 10:37:11 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-05-28 10:40:00 +0200
commit97d90615631d80b95251f163c47d9e4e337ad8d8 (patch)
treec6921365711a53ed0064534fb48687156341bdc7 /meson.build
parent018eaf7445e4059b622ea6743c9d2eb367238925 (diff)
downloadsystemd-97d90615631d80b95251f163c47d9e4e337ad8d8.tar.gz
meson: use a convenience static library for nspawn core
This makes it easier to link the nspawn implementation to the tests. Right now this just means that nspawn-patch-uid.c is not compiled twice, which is nice, but results in test-patch-uid being slightly bigger, which is not nice. But in general, we should use convenience libs to compile everything just once, as far as possible. Otherwise, once we start compiling a few files here twice, and a few file there thrice, we soon end up in a state where we are doing hundreds of extra compilations. So let's do the "right" thing, even if is might not be more efficient.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 5 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 48851d4af2..83fed46cc7 100644
--- a/meson.build
+++ b/meson.build
@@ -1258,6 +1258,7 @@ includes = include_directories('src/basic',
'src/shared',
'src/systemd',
'src/journal',
+ 'src/nspawn',
'src/resolve',
'src/timesync',
'src/time-wait-sync',
@@ -2461,12 +2462,10 @@ exe = executable('systemd-nspawn',
'src/core/mount-setup.h',
'src/core/loopback-setup.c',
'src/core/loopback-setup.h',
- include_directories : [includes, include_directories('src/nspawn')],
- link_with : [libshared],
- dependencies : [libacl,
- libblkid,
- libseccomp,
- libselinux],
+ include_directories : includes,
+ link_with : [libnspawn_core,
+ libshared],
+ dependencies : [libblkid],
install_rpath : rootlibexecdir,
install : true)
public_programs += [exe]