summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichael Biebl <mbiebl@gmail.com>2017-06-23 03:23:30 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-06-22 21:23:30 -0400
commit7cdd9783460b6cec5321ff2c1dd8f7148a82a19d (patch)
treec68229ad6e8acc6d1a96d8f59b82f168210332ef /meson.build
parent53ec2a3226012374e6efce6c0a82cecd6149f52b (diff)
downloadsystemd-7cdd9783460b6cec5321ff2c1dd8f7148a82a19d.tar.gz
meson: install manual and unsafe tests (#6178)
Always install all tests if install-tests is set to true, as they might be useful for CI. This includes manual and unsafe tests. Install those in subdirectories of /usr/lib/systemd/tests. Fixes #6163.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index cab08dc67d..301c8a913d 100644
--- a/meson.build
+++ b/meson.build
@@ -2219,8 +2219,6 @@ foreach tuple : tests
endif
if condition == '' or conf.get(condition, false)
- install = install_tests and type == ''
-
exe = executable(
name,
sources,
@@ -2229,8 +2227,8 @@ foreach tuple : tests
dependencies : dependencies,
c_args : defs,
install_rpath : rootlibexecdir,
- install : install,
- install_dir : testsdir)
+ install : install_tests,
+ install_dir : join_paths(testsdir, type))
if type == 'manual'
message('@0@ is a manual test'.format(name))