summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichal Sekletar <msekleta@redhat.com>2019-09-03 10:05:42 +0200
committerThe Plumber <50238977+systemd-rhel-bot@users.noreply.github.com>2019-10-21 11:22:12 +0200
commit9f259b46b760b2aa08ac1fe76fe61df514e2768f (patch)
tree1932286ed376bf4cd8a8253a3df511781f318169 /meson.build
parent985837dab9c892858a92ae50043843307f5e0714 (diff)
downloadsystemd-9f259b46b760b2aa08ac1fe76fe61df514e2768f.tar.gz
buildsys: don't garbage collect sections while linking
gc-sections is actually very aggressive and garbage collects ELF sections used by annobin gcc plugin and annocheck then reports gaps in coverage. Let's drop that linker flag. RHEL-only Resolves: #1748258
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 0 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 04b461dcd4..613a5133b6 100644
--- a/meson.build
+++ b/meson.build
@@ -357,8 +357,6 @@ if get_option('buildtype') != 'debug'
'-ffunction-sections',
'-fdata-sections',
]
-
- possible_link_flags += '-Wl,--gc-sections'
endif
add_project_arguments(cc.get_supported_arguments(possible_cc_flags), language : 'c')