summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichal Sekletár <msekleta@redhat.com>2019-11-18 12:50:11 +0100
committerThe Plumber <50238977+systemd-rhel-bot@users.noreply.github.com>2019-12-05 15:17:20 +0100
commita735699a8287c19e043b7d2fe9a387a3938e1e2f (patch)
tree4e64f4b42fb0b553fbb6dbba2c35dcb568eed5d2 /meson.build
parent35894625624f0e8c7d3ca2c200861005c7ad4435 (diff)
downloadsystemd-a735699a8287c19e043b7d2fe9a387a3938e1e2f.tar.gz
core: introduce NUMAPolicy and NUMAMask options
Make possible to set NUMA allocation policy for manager. Manager's policy is by default inherited to all forked off processes. However, it is possible to override the policy on per-service basis. Currently we support, these policies: default, prefer, bind, interleave, local. See man 2 set_mempolicy for details on each policy. Overall NUMA policy actually consists of two parts. Policy itself and bitmask representing NUMA nodes where is policy effective. Node mask can be specified using related option, NUMAMask. Default mask can be overwritten on per-service level. (cherry-picked from commit fe9c54b2188e6cd23262a319f96b13215f2c5e9c) Resolves: #1734787
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 613a5133b6..fe82ca4ac2 100644
--- a/meson.build
+++ b/meson.build
@@ -501,6 +501,10 @@ foreach ident : [
#include <unistd.h>'''],
['explicit_bzero' , '''#include <string.h>'''],
['reallocarray', '''#include <malloc.h>'''],
+ ['set_mempolicy', '''#include <stdlib.h>
+ #include <unistd.h>'''],
+ ['get_mempolicy', '''#include <stdlib.h>
+ #include <unistd.h>'''],
]
have = cc.has_function(ident[0], prefix : ident[1], args : '-D_GNU_SOURCE')