summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2018-04-19 03:24:23 +0900
committerYu Watanabe <watanabe.yu+github@gmail.com>2018-04-19 03:24:23 +0900
commitc2e84cab3afb09e726be40ce80b6ce6129c8af32 (patch)
treec690f9500aa19db5f6f686a1dc6df65b95ffcae2 /meson.build
parentedd1dcd091bf7df555f099d68033a4405b804070 (diff)
downloadsystemd-c2e84cab3afb09e726be40ce80b6ce6129c8af32.tar.gz
resolvectl: rename systemd-resolve to resolvectl
For the compatibility, `systemd-resolve` will be created as a symbolic link to `resolvectl`.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 7 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 6b633dfb6d..734a289755 100644
--- a/meson.build
+++ b/meson.build
@@ -1593,8 +1593,8 @@ if conf.get('ENABLE_RESOLVE') == 1
install : true,
install_dir : rootlibexecdir)
- exe = executable('systemd-resolve',
- systemd_resolve_sources,
+ exe = executable('resolvectl',
+ resolvectl_sources,
include_directories : includes,
link_with : [libshared,
libbasic_gcrypt,
@@ -1608,8 +1608,12 @@ if conf.get('ENABLE_RESOLVE') == 1
public_programs += [exe]
meson.add_install_script(meson_make_symlink,
- join_paths(bindir, 'systemd-resolve'),
+ join_paths(bindir, 'resolvectl'),
join_paths(rootsbindir, 'resolvconf'))
+
+ meson.add_install_script(meson_make_symlink,
+ join_paths(bindir, 'resolvectl'),
+ join_paths(bindir, 'systemd-resolve'))
endif
if conf.get('ENABLE_LOGIND') == 1