summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-02-22 23:13:22 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-05-07 22:49:12 -0400
commit5c72049f91b82c8edb64840343df41329f81c7f6 (patch)
tree6e885d209b7e4921dbea4e490cd52571b19e14c2 /meson.build
parentff524019efda6d504dbdddbe5ba6aa3cffb2a7b4 (diff)
downloadsystemd-5c72049f91b82c8edb64840343df41329f81c7f6.tar.gz
udev: use LOG_REALM_UDEV in all udev code
Any call to set/query/use the log level in the code with LOG_REALM=LOG_REALM_UDEV refers to log_max_level[1]. In particular this means that systemd code using the libudev library uses does not set the log level for log calls done in libudev. Fixes #4525. v2: - also update meson's meson.build
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 14a20530d4..6d62ec7fab 100644
--- a/meson.build
+++ b/meson.build
@@ -2055,6 +2055,7 @@ public_programs += [exe]
exe = executable('systemd-udevd',
systemd_udevd_sources,
include_directories : includes,
+ c_args : ['-DLOG_REALM=LOG_REALM_UDEV'],
link_with : [libudev_core,
libsystemd_network,
libudev_internal],