summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2020-02-01 11:01:41 +0900
committerLennart Poettering <lennart@poettering.net>2020-02-01 12:13:45 +0100
commitaf06ddf51a8aeff452a13f597e46a9198c977158 (patch)
tree19d460981f353facaac614191e690e18c4e6f62f /meson.build
parent2273ecfeda0b5efd33077fe6c49f5b86350b507c (diff)
downloadsystemd-af06ddf51a8aeff452a13f597e46a9198c977158.tar.gz
meson, man: do not install pam_systemd_home(8) when pam or homed is disabled
Fixes #14725.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ea69276019..2175ccac1d 100644
--- a/meson.build
+++ b/meson.build
@@ -1343,6 +1343,9 @@ else
endif
conf.set10('ENABLE_HOMED', have)
+have = have and conf.get('HAVE_PAM') == 1
+conf.set10('ENABLE_PAM_HOME', have)
+
want_remote = get_option('remote')
if want_remote != 'false'
have_deps = [conf.get('HAVE_MICROHTTPD') == 1,