summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-12-10 13:04:39 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2020-03-28 11:46:48 +0100
commitfbaa11372bd0f956bb92aa905e2e6981c1ff5f1b (patch)
treebb4668a107839fed60542e12749150bed40d30d3 /meson.build
parent01efa07960c2200ce89e9d25f29869478c1e9520 (diff)
downloadsystemd-fbaa11372bd0f956bb92aa905e2e6981c1ff5f1b.tar.gz
test: convert TEST-35-NETWORK-GENERATOR into a unit test
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d763e81342..360318b7d8 100644
--- a/meson.build
+++ b/meson.build
@@ -2962,13 +2962,20 @@ if conf.get('ENABLE_NETWORKD') == 1
install_dir : rootbindir)
public_programs += exe
- executable('systemd-network-generator',
+ exe = executable('systemd-network-generator',
network_generator_sources,
include_directories : includes,
link_with : [networkd_link_with],
install_rpath : rootlibexecdir,
install : true,
install_dir : rootlibexecdir)
+
+ if want_tests != 'false'
+ test('test-network-generator-conversion',
+ test_network_generator_conversion_sh,
+ # https://github.com/mesonbuild/meson/issues/2681
+ args : exe.full_path())
+ endif
endif
executable('systemd-sulogin-shell',