summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNorbert Lange <nolange79@gmail.com>2020-05-26 10:26:12 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2020-06-01 09:41:21 +0200
commit63e2d1714eedf884ebd9dd865a9dae8ae670d074 (patch)
treef16d1b52337cbbf511a06f96231fae470a5b2623 /meson.build
parent0e77fc66bceb9832da82a56a4c1040fe49f8d805 (diff)
downloadsystemd-63e2d1714eedf884ebd9dd865a9dae8ae670d074.tar.gz
udev: single binary replacing udevd and udevadm
Since the separate binaries contain mostly the same code, this almost halves the size of the installation. before: 398K /bin/udevadm 391K /lib/systemd/systemd-udevd after: 431K /bin/udevadm 0 /lib/systemd/systemd-udevd -> ../../bin/udevadm Fixes: #14200
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build22
1 files changed, 4 insertions, 18 deletions
diff --git a/meson.build b/meson.build
index 008fd998e9..1df2ee8648 100644
--- a/meson.build
+++ b/meson.build
@@ -2198,6 +2198,10 @@ foreach alias : (['halt', 'poweroff', 'reboot', 'shutdown'] +
join_paths(rootsbindir, alias))
endforeach
+meson.add_install_script(meson_make_symlink,
+ join_paths(rootbindir, 'udevadm'),
+ join_paths(rootlibexecdir, 'systemd-udevd'))
+
if conf.get('ENABLE_BACKLIGHT') == 1
executable(
'systemd-backlight',
@@ -2984,24 +2988,6 @@ public_programs += executable(
install_dir : rootlibexecdir)
public_programs += executable(
- 'systemd-udevd',
- systemd_udevd_sources,
- include_directories : includes,
- c_args : '-DLOG_REALM=LOG_REALM_UDEV',
- link_with : [libudev_core,
- libsystemd_network,
- libudev_static],
- dependencies : [versiondep,
- threads,
- libkmod,
- libidn,
- libacl,
- libblkid],
- install_rpath : udev_rpath,
- install : true,
- install_dir : rootlibexecdir)
-
-public_programs += executable(
'udevadm',
udevadm_sources,
c_args : '-DLOG_REALM=LOG_REALM_UDEV',